Resetting the Logitech K810 bluetooth keyboard

The Logitech K810 has been my favorite keyboard for many years. I have one at home and one in the office. It allows to easily switch between 3 different devices. It has the same size and layout as most notebooks, is stylish, and a blast to type.
But one day about a year ago something strange happened. When I wanted to type a ‘\’ I got nothing. When I wanted to type a ‘<‘, I would get a ‘§’. When I wanted to type a ‘>’, I would get a ‘°’. And vice versa. So, effectively two keys were swapped. This was only on the Windows workstation in the office. When I switched the keyboard to the Linux notebook or to the phone, all keys were correct. It also never happened at home.
At first I thought this was a joke by my co-workers. So I tried everything on the windows machine: un-pairing and re-pairing. Scanning the registry for uncommon key mappings. Nothing helped until I found a page that described how to perform a factory reset on the keyboard. The problem was solved, but only for a year. Last week when I came to work after the weekend, the very same keys were swapped again. Finding the page with the reset instructions was more difficult than I remembered. It was not freely available, but only after logging in on the Logitech support page. That is why I want to preserve it here, in case it happens again to me or anybody else:

  • un-pair and remove the keyboard from the bluetooth settings on your pc
  • reset your keyboard: with keyboard on and unpaired from any device, press the following key sequence:
  • “Escape”, “o”,“Escape”, “o”,“Escape”, “b”
  • if the reset is accepted the lights on top of your K810 will blink for a second
  • reconnect your K810 to your pc and test it on other devices if possible.

13 Replies to “Resetting the Logitech K810 bluetooth keyboard”

  1. Thank you, somehow i came across this post and it helped me get my K810 back to normal, was driving me made, i had ripped out the bluetooth, blueman, bluez etc, adjusted my memory settings incase my small overclock had corrupted something and generally started tearing my hair out ! So thank you once again, this was very helpful

  2. Hi Richi,

    Currently I have the same issue, but I haven’t been able to solve it with your instructions. Right now:
    If I hit “f” I get nothing.
    If I hit “z” I get “zf”
    If I hit “o” I get “o,”
    And so on with other keys…

    Can you let me right sequence to for pressing the “Esc”, “o” and “b” keys? I found the explanation for another keyboard model and it is: Esc + O at the same time, twice, and then Esc + B at the same time, but nothing happens.

    Your help will be appreciated.

  3. Aw, this is awesome – thanks so much for posting this! I actually had a new keyboard in my Amazon Cart because I figured this one had finally cracked after 4+ years!

  4. This worked like a charm to reset my Logitech K375s. But the question to the article writer is how he could get this top secret sequence of keys for resetting the keyboard?

  5. Hello Ulrichard,

    I just want to thank you for your contribution. The method worked perfectly in my case. The “p”, “b” and “F1” had stopped working or had some strange reaction like shutting down the document I was working on etc. I was about to throw the keyboard away, because I thought I had damaged it mechanically somehow unwittingly. But it works again as normal thanks to your description.

    I can just say to all for whom it didn’t work yet, make sure to unpair with absolutely all possible devices, if necessary switch them all off. Then hit the keys in the sequence given in Ulrichard’s description one after the other, not two at the same time, which I also tried in the beginning. And while you are hitting the keys, watch the three LEDs at the upper left of the keyboard closely, they are going to blink for less than a second actually, which can be overlooked.

Leave a Reply

Your email address will not be published. Required fields are marked *